aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 17 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 64179e1..83f3da1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,9 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.57.0"
name = "base64"
-version = "0.13.1"
+version = "0.21.0"
authors = [
"Alice Maz <alice@alicemaz.com>",
"Marshall Pierce <marshall@mpierce.org>",
@@ -28,24 +29,34 @@ keywords = [
"no_std",
]
categories = ["encoding"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/marshallpierce/rust-base64"
[profile.bench]
debug = true
+[profile.test]
+opt-level = 3
+
[[bench]]
name = "benchmarks"
harness = false
[dev-dependencies.criterion]
-version = "=0.3.2"
+version = "0.4.0"
[dev-dependencies.rand]
-version = "0.6.1"
+version = "0.8.5"
+features = ["small_rng"]
+
+[dev-dependencies.rstest]
+version = "0.12.0"
+
+[dev-dependencies.rstest_reuse]
+version = "0.3.0"
[dev-dependencies.structopt]
-version = "0.3"
+version = "0.3.26"
[features]
alloc = []