aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 5 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f02d695..453a24f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,8 +11,9 @@
# will likely look very different (and much more reasonable)
[package]
+edition = "2018"
name = "bstr"
-version = "0.2.15"
+version = "0.2.16"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
exclude = ["/.github"]
description = "A string type that is not required to be valid UTF-8."
@@ -29,11 +30,11 @@ debug = true
[lib]
bench = false
[dependencies.lazy_static]
-version = "1.2"
+version = "1.2.0"
optional = true
[dependencies.memchr]
-version = "2.1.2"
+version = "2.4.0"
default-features = false
[dependencies.regex-automata]
@@ -59,10 +60,5 @@ version = "1.2.1"
default = ["std", "unicode"]
serde1 = ["std", "serde1-nostd", "serde/std"]
serde1-nostd = ["serde"]
-std = ["memchr/use_std"]
+std = ["memchr/std"]
unicode = ["lazy_static", "regex-automata"]
-[badges.appveyor]
-repository = "BurntSushi/bstr"
-
-[badges.travis-ci]
-repository = "BurntSushi/bstr"