aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKaiyi Li <kaiyili@google.com>2023-07-29 03:42:46 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2023-07-29 03:42:46 +0000
commitbb13b1d3927664a97792774251b22366fe33b026 (patch)
tree3f106d83efd21dbe7c8e355d0b66447aa973519f /Cargo.toml
parent3dc91939ea2397c9fdc3635653162d429dbecce1 (diff)
parent8ff219fec22001ab03625471a59623644108cfbf (diff)
downloadbytemuck-bb13b1d3927664a97792774251b22366fe33b026.tar.gz
Import 'bytemuck' crate am: 8ff219fec2
Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/bytemuck/+/2673745 Change-Id: If7d24e88e4cf1c62bdde968abde3d199bb040da8 Signed-off-by: Automerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b7d55e8
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "bytemuck"
+version = "1.13.1"
+authors = ["Lokathor <zefria@gmail.com>"]
+exclude = ["/pedantic.bat"]
+description = "A crate for mucking around with piles of bytes."
+readme = "README.md"
+keywords = [
+ "transmute",
+ "bytes",
+ "casting",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
+license = "Zlib OR Apache-2.0 OR MIT"
+repository = "https://github.com/Lokathor/bytemuck"
+
+[package.metadata.docs.rs]
+features = [
+ "derive",
+ "extern_crate_alloc",
+ "extern_crate_std",
+ "zeroable_maybe_uninit",
+ "zeroable_atomics",
+ "min_const_generics",
+ "wasm_simd",
+]
+
+[package.metadata.playground]
+features = [
+ "derive",
+ "extern_crate_alloc",
+ "extern_crate_std",
+ "zeroable_maybe_uninit",
+ "zeroable_atomics",
+ "min_const_generics",
+ "wasm_simd",
+]
+
+[dependencies.bytemuck_derive]
+version = "1.4"
+optional = true
+
+[features]
+aarch64_simd = []
+derive = ["bytemuck_derive"]
+extern_crate_alloc = []
+extern_crate_std = ["extern_crate_alloc"]
+min_const_generics = []
+nightly_portable_simd = []
+nightly_stdsimd = []
+unsound_ptr_pod_impl = []
+wasm_simd = []
+zeroable_atomics = []
+zeroable_maybe_uninit = []