aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml52
1 files changed, 31 insertions, 21 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 91f2aa3..fb2acad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,38 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
[package]
name = "byteorder"
-version = "1.3.2" #:version
+version = "1.3.2"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
+build = "build.rs"
+exclude = ["/ci/*"]
description = "Library for reading/writing numbers in big-endian and little-endian."
-documentation = "https://docs.rs/byteorder"
homepage = "https://github.com/BurntSushi/byteorder"
-repository = "https://github.com/BurntSushi/byteorder"
+documentation = "https://docs.rs/byteorder"
readme = "README.md"
-categories = ["encoding", "parsing"]
keywords = ["byte", "endian", "big-endian", "little-endian", "binary"]
+categories = ["encoding", "parsing"]
license = "Unlicense OR MIT"
-exclude = ["/ci/*"]
-build = "build.rs"
+repository = "https://github.com/BurntSushi/byteorder"
+[profile.bench]
+opt-level = 3
[lib]
name = "byteorder"
bench = false
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.quickcheck]
+version = "0.8"
+default-features = false
-[dev-dependencies]
-quickcheck = { version = "0.8", default-features = false }
-rand = "0.6"
-doc-comment = "0.3"
+[dev-dependencies.rand]
+version = "0.6"
[features]
default = ["std"]
-std = []
-
-# This feature is no longer used and is DEPRECATED. This crate now
-# automatically enables i128 support for Rust compilers that support it. The
-# feature will be removed if and when a new major version is released.
i128 = []
-
-[profile.bench]
-opt-level = 3
-
-[badges]
-travis-ci = { repository = "BurntSushi/byteorder" }
+std = []
+[badges.travis-ci]
+repository = "BurntSushi/byteorder"