aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 20 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5ddfdc6..9d64276 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,39 +3,48 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "criterion-plot"
-version = "0.4.4"
-authors = ["Jorge Aparicio <japaricious@gmail.com>", "Brook Heisler <brookheisler@gmail.com>"]
+version = "0.5.0"
+authors = [
+ "Jorge Aparicio <japaricious@gmail.com>",
+ "Brook Heisler <brookheisler@gmail.com>",
+]
description = "Criterion's plotting library"
readme = "README.md"
-keywords = ["plotting", "gnuplot", "criterion"]
+keywords = [
+ "plotting",
+ "gnuplot",
+ "criterion",
+]
categories = ["visualization"]
license = "MIT/Apache-2.0"
repository = "https://github.com/bheisler/criterion.rs"
+
[dependencies.cast]
-version = "0.2"
+version = "0.3"
[dependencies.itertools]
version = "0.10"
+
[dev-dependencies.itertools-num]
version = "0.1"
[dev-dependencies.num-complex]
-version = "0.2"
+version = "0.4"
features = ["std"]
default-features = false
[dev-dependencies.rand]
-version = "0.4"
+version = "0.8"
+
[badges.appveyor]
id = "4255ads9ctpupcl2"
repository = "bheisler/criterion.rs"