aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..0f43cb0
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "csv-core"
+version = "0.1.10"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = "Bare bones CSV parsing with no_std support."
+homepage = "https://github.com/BurntSushi/rust-csv"
+documentation = "https://docs.rs/csv-core"
+readme = "README.md"
+keywords = ["csv", "comma", "parser", "delimited", "no_std"]
+categories = ["encoding", "no-std", "parser-implementations"]
+license = "Unlicense/MIT"
+repository = "https://github.com/BurntSushi/rust-csv"
+
+[lib]
+bench = false
+[dependencies.memchr]
+version = "2"
+default-features = false
+[dev-dependencies.arrayvec]
+version = "0.5"
+default-features = false
+
+[features]
+default = []
+libc = ["memchr/libc"]
+[badges.appveyor]
+repository = "BurntSushi/rust-csv"
+
+[badges.travis-ci]
+repository = "BurntSushi/rust-csv"