aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid LeGare <legare@google.com>2022-03-02 00:20:44 +0000
committerDavid LeGare <legare@google.com>2022-03-02 00:20:44 +0000
commitf7dc9c1e422a35a714d514f036f6fa506f6eadc1 (patch)
tree4bd872c7931921cfe12cc2fa1b72915778e481d3 /Cargo.toml
parentb45a6c57b861d2295096f86510d454228043dd40 (diff)
downloadfutures-channel-f7dc9c1e422a35a714d514f036f6fa506f6eadc1.tar.gz
Update futures-channel to 0.3.21
Test: cd external/rust/crates && atest --host -c Change-Id: I9c1e17e5ea84d783817d5e69955f4c685e005721
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 17 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bea8d51..d0a13f6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,23 +11,29 @@
[package]
edition = "2018"
+rust-version = "1.45"
name = "futures-channel"
-version = "0.3.17"
-authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = "Channels for asynchronous communication using futures-rs.\n"
+version = "0.3.21"
+description = """
+Channels for asynchronous communication using futures-rs.
+"""
homepage = "https://rust-lang.github.io/futures-rs"
-documentation = "https://docs.rs/futures-channel/0.3"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/futures-rs"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.futures-core]
-version = "0.3.17"
+version = "0.3.21"
default-features = false
[dependencies.futures-sink]
-version = "0.3.17"
+version = "0.3.21"
optional = true
default-features = false
@@ -38,5 +44,8 @@ alloc = ["futures-core/alloc"]
cfg-target-has-atomic = []
default = ["std"]
sink = ["futures-sink"]
-std = ["alloc", "futures-core/std"]
+std = [
+ "alloc",
+ "futures-core/std",
+]
unstable = []