aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid LeGare <legare@google.com>2022-03-05 01:56:14 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2022-03-05 01:56:14 +0000
commitd97505630bfc2d27502dcffce98a1f6964aaf855 (patch)
tree4bd872c7931921cfe12cc2fa1b72915778e481d3 /Cargo.toml
parent56f3d1d3a3328ad0c3d1feb62d96940e1af14ea9 (diff)
parent99a38b94a877e6a9bf59533a392a085ad5a5f38b (diff)
downloadfutures-channel-d97505630bfc2d27502dcffce98a1f6964aaf855.tar.gz
Update futures-channel to 0.3.21 am: f7dc9c1e42 am: 99a38b94a8
Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/futures-channel/+/2005931 Change-Id: I61ee6190d220782aeb55a48cea599d396f100fb4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 17 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bea8d51..d0a13f6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,23 +11,29 @@
[package]
edition = "2018"
+rust-version = "1.45"
name = "futures-channel"
-version = "0.3.17"
-authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = "Channels for asynchronous communication using futures-rs.\n"
+version = "0.3.21"
+description = """
+Channels for asynchronous communication using futures-rs.
+"""
homepage = "https://rust-lang.github.io/futures-rs"
-documentation = "https://docs.rs/futures-channel/0.3"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/futures-rs"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.futures-core]
-version = "0.3.17"
+version = "0.3.21"
default-features = false
[dependencies.futures-sink]
-version = "0.3.17"
+version = "0.3.21"
optional = true
default-features = false
@@ -38,5 +44,8 @@ alloc = ["futures-core/alloc"]
cfg-target-has-atomic = []
default = ["std"]
sink = ["futures-sink"]
-std = ["alloc", "futures-core/std"]
+std = [
+ "alloc",
+ "futures-core/std",
+]
unstable = []