summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Vander Stoep <jeffv@google.com>2020-10-14 15:35:59 +0200
committerJeff Vander Stoep <jeffv@google.com>2020-10-14 15:44:30 +0200
commit3adfea8b276f06db63ae4182233560537aca2ffb (patch)
treea543e650c0d9b57239020605562e73d35f9db409 /Cargo.toml
parente028ffbabf8620351ce637bb48a8bb539c753c38 (diff)
downloadgrpcio-sys-3adfea8b276f06db63ae4182233560537aca2ffb.tar.gz
Import grpcio-sys 0.6.0
And add metadata files using the following command: get_rust_pkg.py --add3prf -v grpcio-sys-0.6.0 -o grpcio-sys Use LICENSE file from parent grpcio crate. Add README.android as requested during security review. Test: None Change-Id: Ib5f5c2af6f51d50c536cc4b6979666d480a57041
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000..6c57722d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "grpcio-sys"
+version = "0.6.0"
+authors = ["The TiKV Project Developers"]
+build = "build.rs"
+exclude = ["grpc/doc/*", "grpc/etc/*", "grpc/examples/*", "grpc/Makefile", "grpc/templates/*", "grpc/src/android/*", "grpc/src/csharp/*", "grpc/src/node/*", "grpc/src/objective-c/*", "grpc/src/php/*", "grpc/src/python/*", "grpc/src/ruby/*", "grpc/test/core/end2end/*", "grpc/third_party/zlib/*", "grpc/third_party/abseil-cpp/absl/time/internal/cctz/testdata", "grpc/third_party/benchmark/*", "grpc/third_party/bloaty/*", "grpc/third_party/boringssl-with-bazel/crypto_test_data.cc", "grpc/third_party/boringssl-with-bazel/src/fuzz", "grpc/third_party/boringssl-with-bazel/src/crypto/cipher_extra/test", "grpc/third_party/boringssl-with-bazel/src/third_party/wycheproof_testvectors", "grpc/third_party/boringssl-with-bazel/src/third_party/googletest", "grpc/third_party/libuv/*", "grpc/third_party/gflags/*", "grpc/third_party/googletest/*", "grpc/third_party/objective_c/*", "grpc/third_party/protobuf/*", "grpc/third_party/toolchans/*", "grpc/third_party/envoy-api/*", "grpc/third_party/googleapis/*", "grpc/third_party/protoc-gen-validate/*", "grpc/third_party/udpa/*", "grpc/tools/run_tests/generated/*", "grpc/test/core/", "!grpc/test/core/security/*.cc", "!grpc/test/core/util/cmdline.cc", "grpc/test/cpp"]
+description = "FFI bindings to gRPC c core library"
+homepage = "https://github.com/tikv/grpc-rs"
+documentation = "https://docs.rs/grpcio-sys"
+keywords = ["grpc", "bindings"]
+categories = ["external-ffi-bindings", "network-programming"]
+license = "Apache-2.0"
+repository = "https://github.com/tikv/grpc-rs"
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.libz-sys]
+version = "1.0.25"
+features = ["static"]
+
+[dependencies.openssl-sys]
+version = "0.9"
+features = ["vendored"]
+optional = true
+[build-dependencies.bindgen]
+version = "0.51.0"
+default-features = false
+
+[build-dependencies.cc]
+version = "1.0"
+
+[build-dependencies.cmake]
+version = "0.1"
+
+[build-dependencies.pkg-config]
+version = "0.3"
+
+[build-dependencies.walkdir]
+version = "2.2.9"
+
+[features]
+default = []
+no-omit-frame-pointer = []
+openssl = ["secure"]
+openssl-vendored = ["openssl", "openssl-sys"]
+secure = []