aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 9 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 92db926..308f9f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "hashlink"
-version = "0.7.0"
+version = "0.8.1"
authors = ["kyren <kerriganw@gmail.com>"]
description = "HashMap-like containers that hold their key-value pairs in a user controllable order"
documentation = "https://docs.rs/hashlink"
@@ -21,12 +20,14 @@ readme = "README.md"
keywords = ["data-structures"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/kyren/hashlink"
+
[dependencies.hashbrown]
-version = "0.11.0"
+version = "0.12.0"
[dependencies.serde]
version = "1.0"
optional = true
+
[dev-dependencies.fxhash]
version = "0.2.1"
@@ -35,6 +36,7 @@ version = "1.0"
[features]
serde_impl = ["serde"]
+
[badges.circle-ci]
branch = "master"
repository = "kyren/hashlink"