aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml126
1 files changed, 88 insertions, 38 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2037f0b..437a36e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,57 +1,107 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
[package]
-name = "indexmap"
edition = "2021"
-version = "2.0.0-pre"
-publish = false
+rust-version = "1.56"
+name = "indexmap"
+version = "1.9.2"
+description = "A hash table with consistent order and fast iteration."
documentation = "https://docs.rs/indexmap/"
-repository = "https://github.com/bluss/indexmap"
+readme = "README.md"
+keywords = [
+ "hashmap",
+ "no_std",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
license = "Apache-2.0 OR MIT"
-description = "A hash table with consistent order and fast iteration."
-keywords = ["hashmap", "no_std"]
-categories = ["data-structures", "no-std"]
-rust-version = "1.56"
+repository = "https://github.com/bluss/indexmap"
+
+[package.metadata.release]
+no-dev-version = true
+tag-name = "{{version}}"
+
+[package.metadata.docs.rs]
+features = [
+ "arbitrary",
+ "quickcheck",
+ "serde-1",
+ "rayon",
+]
+
+[profile.bench]
+debug = true
[lib]
bench = false
-[dependencies]
-serde = { version = "1.0", optional = true, default-features = false }
-rayon = { version = "1.4.1", optional = true }
-
-# Internal feature, only used when building as part of rustc,
-# not part of the stable interface of this crate.
-rustc-rayon = { version = "0.4", optional = true }
+[dependencies.arbitrary]
+version = "1.0"
+optional = true
+default-features = false
[dependencies.hashbrown]
version = "0.12"
-default-features = false
features = ["raw"]
+default-features = false
-[dev-dependencies]
-itertools = "0.10"
-rand = {version = "0.8", features = ["small_rng"] }
-quickcheck = { version = "1.0", default-features = false }
-fnv = "1.0"
-lazy_static = "1.3"
-fxhash = "0.2.1"
-serde_derive = "1.0"
+[dependencies.quickcheck]
+version = "1.0"
+optional = true
+default-features = false
-[features]
-default = ["std"]
-std = []
+[dependencies.rayon]
+version = "1.4.1"
+optional = true
-# for testing only, of course
-test_debug = []
+[dependencies.rustc-rayon]
+version = "0.4"
+optional = true
-[profile.bench]
-debug = true
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
-[package.metadata.release]
-no-dev-version = true
-tag-name = "{{version}}"
+[dev-dependencies.fnv]
+version = "1.0"
-[package.metadata.docs.rs]
-features = ["serde", "rayon"]
+[dev-dependencies.fxhash]
+version = "0.2.1"
-[workspace]
-members = ["test-nostd", "test-serde"]
+[dev-dependencies.itertools]
+version = "0.10"
+
+[dev-dependencies.lazy_static]
+version = "1.3"
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+features = ["small_rng"]
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+serde-1 = ["serde"]
+std = []
+test_debug = []
+test_low_transition_point = []