aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml84
1 files changed, 84 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1031381
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,84 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "instant"
+version = "0.1.7"
+authors = ["sebcrozet <developer@crozet.re>"]
+description = "A partial replacement for std::time::Instant that works on WASM too."
+readme = "README.md"
+keywords = ["time", "wasm"]
+license = "BSD-3-Clause"
+repository = "https://github.com/sebcrozet/instant"
+[dependencies.cfg-if]
+version = "0.1"
+[dev-dependencies.wasm-bindgen-test]
+version = "0.2"
+
+[features]
+now = ["time"]
+wasm-bindgen = ["js-sys", "wasm-bindgen_rs", "web-sys"]
+[target.asmjs-unknown-emscripten.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.asmjs-unknown-emscripten.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.asmjs-unknown-emscripten.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.asmjs-unknown-emscripten.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true
+[target."cfg(not(any(feature = \"stdweb\", feature = \"wasm-bindgen\")))".dependencies.time]
+version = "0.1"
+optional = true
+[target.wasm32-unknown-emscripten.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.wasm32-unknown-emscripten.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.wasm32-unknown-emscripten.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.wasm32-unknown-emscripten.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true
+[target.wasm32-unknown-unknown.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.wasm32-unknown-unknown.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.wasm32-unknown-unknown.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.wasm32-unknown-unknown.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true