aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 17 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 02b4382..86c10b6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,20 +10,29 @@
# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
+rust-version = "1.36"
name = "itoa"
-version = "0.4.8"
+version = "1.0.5"
authors = ["David Tolnay <dtolnay@gmail.com>"]
-exclude = ["performance.png"]
-description = "Fast functions for printing integer primitives to an io::Write"
+exclude = [
+ "performance.png",
+ "chart/**",
+]
+description = "Fast integer primitive to string conversion"
documentation = "https://docs.rs/itoa"
readme = "README.md"
-categories = ["value-formatting"]
+keywords = ["integer"]
+categories = [
+ "value-formatting",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/itoa"
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
-[features]
-default = ["std"]
-i128 = []
-std = []
+[dependencies.no-panic]
+version = "0.1"
+optional = true