aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgnzlbg <gonzalobg88@gmail.com>2019-05-24 13:22:03 +0200
committergnzlbg <gonzalobg88@gmail.com>2019-05-24 13:22:03 +0200
commit4ac26afa83e83bd1da49b637af814f56515c8184 (patch)
treef3e37560af00ed0a1bb328ba94d48060d8378897 /Cargo.toml
parentf775bea997307fe701e05952c1c97877b40c9f9f (diff)
downloadlibc-4ac26afa83e83bd1da49b637af814f56515c8184.tar.gz
Deprecate `use_std` cargo feature: use `std` instead .
Related to #657 .
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ef500be2..b40aff9e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,11 +23,13 @@ appveyor = { repository = "rust-lang/libc", project_name = "rust-lang-libs/libc"
rustc-std-workspace-core = { version = "1.0.0", optional = true }
[features]
-default = ["use_std"]
-use_std = []
+default = ["std"]
+std = []
align = []
rustc-dep-of-std = ['align', 'rustc-std-workspace-core']
extra_traits = []
+# use_std is deprecated, use `std` instead
+use_std = [ 'std' ]
[workspace]
members = ["libc-test"]