aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgnzlbg <gonzalobg88@gmail.com>2018-11-22 19:05:49 +0100
committergnzlbg <gonzalobg88@gmail.com>2018-11-22 19:06:40 +0100
commit7afe55be24a6475d45b4faba1082fae6816814b2 (patch)
treef41284dd07bed9643481c76f7e1125114fc4d16b /Cargo.toml
parent1eeba38558f5f83cd62901923f4bea8eea90bf82 (diff)
downloadlibc-7afe55be24a6475d45b4faba1082fae6816814b2.tar.gz
Use crates.io keywords and categories
Closes #651 .
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f3e57f83..a89376c4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,12 +7,13 @@ readme = "README.md"
repository = "https://github.com/rust-lang/libc"
homepage = "https://github.com/rust-lang/libc"
documentation = "http://doc.rust-lang.org/libc"
-description = """
-A library for types and bindings to native C functions often found in libc or
-other common platform libraries.
-"""
+keywords = ["libc", "ffi", "bindings", "operating", "system" ]
+categories = ["external-ffi-bindings", "no-std", "os"]
build = "build.rs"
exclude = ["/ci/*", "/.travis.yml", "/appveyor.yml"]
+description = """
+Raw FFI bindings to platform libraries like libc.
+"""
[badges]
travis-ci = { repository = "rust-lang/libc" }