aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 19 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 39b41f3..65168d5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,25 +12,40 @@
[package]
rust-version = "1.40.0"
name = "libloading"
-version = "0.7.3"
+version = "0.7.4"
authors = ["Simonas Kazlauskas <libloading@kazlauskas.me>"]
description = "Bindings around the platform's dynamic library loading primitives with greatly improved memory safety."
documentation = "https://docs.rs/libloading/"
readme = "README.mkd"
-keywords = ["dlopen", "load", "shared", "dylib"]
+keywords = [
+ "dlopen",
+ "load",
+ "shared",
+ "dylib",
+]
categories = ["api-bindings"]
license = "ISC"
repository = "https://github.com/nagisa/rust_libloading/"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "libloading_docs"]
+rustdoc-args = [
+ "--cfg",
+ "libloading_docs",
+]
+
[dev-dependencies.libc]
version = "0.2"
[dev-dependencies.static_assertions]
version = "1.1"
+
[target."cfg(unix)".dependencies.cfg-if]
version = "1"
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3"
-features = ["errhandlingapi", "libloaderapi"]
+features = [
+ "errhandlingapi",
+ "libloaderapi",
+]