aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Walbran <qwandor@google.com>2023-06-01 20:45:50 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2023-06-01 20:45:50 +0000
commit6128694f14608a39f371cb04332203dd55021272 (patch)
treec152abda73624cb4a77225f0682f01b33a76be30 /Cargo.toml
parenteef466dd058ab69a4edff26d5ba602918dc8b071 (diff)
parentc89a47375198fa255d792180bb95dabb268c803f (diff)
downloadlinkme-6128694f14608a39f371cb04332203dd55021272.tar.gz
Initial import am: 2970041c34 am: 59f583acb4 am: a1d0e5dd7b am: e423295327 am: c89a473751
Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/linkme/+/2607228 Change-Id: I1b7d8c24551caff1092e22520b5e90a10f3c4045 Signed-off-by: Automerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d9cf97f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.62"
+name = "linkme"
+version = "0.3.9"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Safe cross-platform linker shenanigans"
+documentation = "https://docs.rs/linkme"
+readme = "README.md"
+keywords = ["linkage"]
+categories = [
+ "development-tools::build-utils",
+ "development-tools::procedural-macro-helpers",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/linkme"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[[test]]
+name = "module_2015"
+edition = "2015"
+
+[dependencies.linkme-impl]
+version = "=0.3.9"
+
+[dev-dependencies.once_cell]
+version = "1.16"
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.66"
+features = ["diff"]
+
+[features]
+used_linker = ["linkme-impl/used_linker"]