aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d9cf97f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.62"
+name = "linkme"
+version = "0.3.9"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Safe cross-platform linker shenanigans"
+documentation = "https://docs.rs/linkme"
+readme = "README.md"
+keywords = ["linkage"]
+categories = [
+ "development-tools::build-utils",
+ "development-tools::procedural-macro-helpers",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/linkme"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[[test]]
+name = "module_2015"
+edition = "2015"
+
+[dependencies.linkme-impl]
+version = "=0.3.9"
+
+[dev-dependencies.once_cell]
+version = "1.16"
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.66"
+features = ["diff"]
+
+[features]
+used_linker = ["linkme-impl/used_linker"]