aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2020-07-28 13:45:57 -0700
committerJoel Galenson <jgalenson@google.com>2020-07-28 13:45:57 -0700
commit891d7cdbb820666e3cbb9a0c8ae42a8bde086ba7 (patch)
tree99a76e39cfb2b37a8a11406c34e4d3bd31ad7f10 /Cargo.toml
parent58c6cd5619aceba2122382fc5444599323a8b0ab (diff)
downloadlru-cache-891d7cdbb820666e3cbb9a0c8ae42a8bde086ba7.tar.gz
Import lru-cache-0.1.2
Change-Id: I59863d9df423e40d8d4eb46e3d463ec2b18212e9
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..25bcbf4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "lru-cache"
+version = "0.1.2"
+authors = ["Stepan Koltsov <stepan.koltsov@gmail.com>"]
+description = "A cache that holds a limited number of key-value pairs"
+homepage = "https://github.com/contain-rs/lru-cache"
+documentation = "https://contain-rs.github.io/lru-cache/lru_cache"
+readme = "README.md"
+keywords = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/contain-rs/lru-cache"
+[dependencies.heapsize]
+version = "0.4"
+optional = true
+
+[dependencies.linked-hash-map]
+version = "0.5"
+
+[features]
+heapsize_impl = ["heapsize", "linked-hash-map/heapsize_impl"]