aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..25bcbf4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "lru-cache"
+version = "0.1.2"
+authors = ["Stepan Koltsov <stepan.koltsov@gmail.com>"]
+description = "A cache that holds a limited number of key-value pairs"
+homepage = "https://github.com/contain-rs/lru-cache"
+documentation = "https://contain-rs.github.io/lru-cache/lru_cache"
+readme = "README.md"
+keywords = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/contain-rs/lru-cache"
+[dependencies.heapsize]
+version = "0.4"
+optional = true
+
+[dependencies.linked-hash-map]
+version = "0.5"
+
+[features]
+heapsize_impl = ["heapsize", "linked-hash-map/heapsize_impl"]