aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..ef6d76b
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "macaddr"
+version = "1.0.1"
+authors = ["svartalf <self@svartalf.info>"]
+exclude = ["/.github", "/fuzz", "/benches"]
+description = "MAC address types"
+readme = "README.md"
+keywords = ["mac", "macaddr", "mac-48", "eui-48", "eui-96"]
+categories = ["data-structures", "network-programming", "no-std"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/svartalf/rust-macaddr"
+[package.metadata.docs.rs]
+features = ["serde", "serde_std"]
+[dependencies.serde]
+version = "^1.0"
+features = ["derive"]
+optional = true
+default-features = false
+[dev-dependencies.assert_matches]
+version = "1.3.0"
+
+[features]
+default = ["std"]
+serde_std = ["std", "serde/std"]
+std = []
+[badges.maintenance]
+status = "passively-maintained"