aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2020-10-23 08:03:13 -0700
committerJoel Galenson <jgalenson@google.com>2020-10-23 08:03:13 -0700
commit4bf0c30e286d482eb711dc677be906adcba4650b (patch)
treede038d1f2268222ebb5925c40db9bda0e2d8e565 /Cargo.toml
parent33e7b955494b6d15ed72863ad35c620e904302ed (diff)
downloadmio-4bf0c30e286d482eb711dc677be906adcba4650b.tar.gz
Import mio-0.7.3
Test: None Change-Id: I7df903972aaf06adb1ecb20a63793fcf128edb8f
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..69de5e0
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,71 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "mio"
+version = "0.7.3"
+authors = ["Carl Lerche <me@carllerche.com>"]
+include = ["Cargo.toml", "LICENSE", "README.md", "CHANGELOG.md", "src/**/*.rs", "examples/**/*.rs"]
+description = "Lightweight non-blocking IO"
+homepage = "https://github.com/tokio-rs/mio"
+documentation = "https://docs.rs/mio/0.7.3"
+readme = "README.md"
+keywords = ["io", "async", "non-blocking"]
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/mio"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[package.metadata.playground]
+features = ["os-poll", "os-util", "tcp", "udp", "uds"]
+
+[[example]]
+name = "tcp_server"
+required-features = ["os-poll", "tcp"]
+
+[[example]]
+name = "udp_server"
+required-features = ["os-poll", "udp"]
+[dependencies.log]
+version = "0.4.8"
+[dev-dependencies.env_logger]
+version = "0.6.2"
+default-features = false
+
+[dev-dependencies.net2]
+version = "0.2.33"
+
+[dev-dependencies.rand]
+version = "0.4"
+
+[features]
+default = []
+extra-docs = []
+os-poll = []
+os-util = []
+tcp = []
+udp = []
+uds = []
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.69"
+[target."cfg(windows)".dependencies.miow]
+version = "0.3.3"
+
+[target."cfg(windows)".dependencies.ntapi]
+version = "0.3"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["winsock2", "mswsock"]