aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 4 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 549151b..6f58afa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "parking_lot"
-version = "0.11.2"
+version = "0.12.0"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "More compact and efficient implementations of the standard synchronization primitives."
readme = "README.md"
@@ -20,14 +20,11 @@ keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
categories = ["concurrency"]
license = "Apache-2.0/MIT"
repository = "https://github.com/Amanieu/parking_lot"
-[dependencies.instant]
-version = "0.1.9"
-
[dependencies.lock_api]
-version = "0.4.5"
+version = "0.4.6"
[dependencies.parking_lot_core]
-version = "0.8.4"
+version = "0.9.0"
[dev-dependencies.bincode]
version = "1.3.3"
@@ -38,9 +35,8 @@ version = "0.8.3"
arc_lock = ["lock_api/arc_lock"]
deadlock_detection = ["parking_lot_core/deadlock_detection"]
default = []
+hardware-lock-elision = []
nightly = ["parking_lot_core/nightly", "lock_api/nightly"]
owning_ref = ["lock_api/owning_ref"]
send_guard = []
serde = ["lock_api/serde"]
-stdweb = ["instant/stdweb"]
-wasm-bindgen = ["instant/wasm-bindgen"]