summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Vander Stoep <jeffv@google.com>2020-10-14 15:10:30 +0200
committerJeff Vander Stoep <jeffv@google.com>2020-10-14 15:10:30 +0200
commitcd07f7348693ec1aa1260392fbbeea574eb1bd7a (patch)
tree606038c0a7e33bc4ced68c148d769e3efef1c36d /Cargo.toml
parent18c5dfd56d007642a05390def0fd108fe56cb53c (diff)
downloadparking_lot_core-cd07f7348693ec1aa1260392fbbeea574eb1bd7a.tar.gz
Import parking_lot_core 0.7.2
And add metadata files using the following command: get_rust_pkg.py --add3prf -v parking_lot_core-0.7.2 -o parking_lot_core Test: none Change-Id: Ic6a5d490ae7c01e5321b465768d402b8302ca448
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d24a5ca
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "parking_lot_core"
+version = "0.7.2"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "An advanced API for creating custom synchronization primitives."
+keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
+categories = ["concurrency"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/Amanieu/parking_lot"
+[dependencies.backtrace]
+version = "0.3.2"
+optional = true
+
+[dependencies.cfg-if]
+version = "0.1.5"
+
+[dependencies.petgraph]
+version = "0.5"
+optional = true
+
+[dependencies.smallvec]
+version = "1.0"
+
+[dependencies.thread-id]
+version = "3.2.0"
+optional = true
+
+[features]
+deadlock_detection = ["petgraph", "thread-id", "backtrace"]
+nightly = []
+[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
+version = "0.0.3"
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.1"
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.55"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]