summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2021-09-22 11:13:35 -0700
committerJoel Galenson <jgalenson@google.com>2021-09-22 11:13:35 -0700
commite339207ab6ad6186957726d5c0c261654e5274f9 (patch)
treeeabda872e663a08047a7f79095ff8114c0f1618b /Cargo.toml
parent5c8a27f88a7de4d1cb325e168b1ecb30f0cb14af (diff)
downloadparking_lot_core-e339207ab6ad6186957726d5c0c261654e5274f9.tar.gz
Upgrade rust/crates/parking_lot_core to 0.8.5
Test: make Change-Id: If108531c5066a38be5a8dd14e0f61efc51acd72c
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 11 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a9184c2..7afeb41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "parking_lot_core"
-version = "0.8.3"
+version = "0.8.5"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "An advanced API for creating custom synchronization primitives."
keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
@@ -21,14 +20,14 @@ categories = ["concurrency"]
license = "Apache-2.0/MIT"
repository = "https://github.com/Amanieu/parking_lot"
[dependencies.backtrace]
-version = "0.3.49"
+version = "0.3.60"
optional = true
[dependencies.cfg-if]
version = "1.0.0"
[dependencies.instant]
-version = "0.1.4"
+version = "0.1.9"
[dependencies.petgraph]
version = "0.5.1"
@@ -38,16 +37,16 @@ optional = true
version = "1.6.1"
[dependencies.thread-id]
-version = "3.3.0"
+version = "4.0.0"
optional = true
[features]
deadlock_detection = ["petgraph", "thread-id", "backtrace"]
nightly = []
[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.4"
+version = "0.2.8"
[target."cfg(unix)".dependencies.libc]
-version = "0.2.71"
+version = "0.2.95"
[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8"
+version = "0.3.9"
features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]