summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 26 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2fdf5e8..8038a70 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,13 +12,20 @@
[package]
edition = "2018"
name = "parking_lot_core"
-version = "0.9.1"
+version = "0.9.5"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "An advanced API for creating custom synchronization primitives."
-keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
+keywords = [
+ "mutex",
+ "condvar",
+ "rwlock",
+ "once",
+ "thread",
+]
categories = ["concurrency"]
-license = "Apache-2.0/MIT"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/parking_lot"
+
[dependencies.backtrace]
version = "0.3.60"
optional = true
@@ -27,7 +34,7 @@ optional = true
version = "1.0.0"
[dependencies.petgraph]
-version = "0.5.1"
+version = "0.6.0"
optional = true
[dependencies.smallvec]
@@ -38,12 +45,24 @@ version = "4.0.0"
optional = true
[features]
-deadlock_detection = ["petgraph", "thread-id", "backtrace"]
+deadlock_detection = [
+ "petgraph",
+ "thread-id",
+ "backtrace",
+]
nightly = []
+
[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
version = "0.2.8"
+
[target."cfg(unix)".dependencies.libc]
version = "0.2.95"
+
[target."cfg(windows)".dependencies.windows-sys]
-version = "0.32"
-features = ["Win32_Foundation", "Win32_System_LibraryLoader", "Win32_System_SystemServices", "Win32_System_WindowsProgramming"]
+version = "0.42.0"
+features = [
+ "Win32_Foundation",
+ "Win32_System_LibraryLoader",
+ "Win32_System_SystemServices",
+ "Win32_System_WindowsProgramming",
+]