aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2021-02-24 11:40:13 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-02-24 11:40:13 +0000
commit80e2414e10860e3c48745df4dbb79860fd48d465 (patch)
treeaa583765ea0c0fd8bddb46d99bb04eae1334edd3 /Cargo.toml
parentdf0f8b492944fcf2e341cf28f2cc9cecaa3c1bb2 (diff)
parent3e9a78f8a652042b466f19f7cfd9a72c7e6967c0 (diff)
downloadpin-project-80e2414e10860e3c48745df4dbb79860fd48d465.tar.gz
Upgrade rust/crates/pin-project to 1.0.5 am: c1311073c0 am: 839279b456 am: 60a03099d2 am: 3e9a78f8a6
Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/pin-project/+/1581962 MUST ONLY BE SUBMITTED BY AUTOMERGER Change-Id: I2e4e3581c6fe655ec346cf5bd7a7c667c4bffd9d
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 6 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 79ba823..f77b1cb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,12 +13,11 @@
[package]
edition = "2018"
name = "pin-project"
-version = "1.0.3"
+version = "1.0.5"
authors = ["Taiki Endo <te316e89@gmail.com>"]
-exclude = ["/.github", "/ci", "/scripts"]
+exclude = ["/.*", "/ci", "/scripts"]
description = "A crate for safe and ergonomic pin-projection.\n"
documentation = "https://docs.rs/pin-project"
-readme = "README.md"
keywords = ["pin", "macros", "attribute"]
categories = ["no-std", "rust-patterns"]
license = "Apache-2.0 OR MIT"
@@ -26,16 +25,16 @@ repository = "https://github.com/taiki-e/pin-project"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
[dependencies.pin-project-internal]
-version = "=1.0.3"
+version = "=1.0.5"
default-features = false
+[dev-dependencies.macrotest]
+version = "1.0.8"
+
[dev-dependencies.rustversion]
version = "1"
[dev-dependencies.static_assertions]
version = "1"
-[dev-dependencies.tempfile]
-version = "3"
-
[dev-dependencies.trybuild]
version = "1"