aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid LeGare <legare@google.com>2022-03-02 16:21:12 +0000
committerDavid LeGare <legare@google.com>2022-03-02 16:21:12 +0000
commit8915193b0de5f14b58aea0cd7bd72a6083529dc2 (patch)
tree80c46c7f97eb0158db00b2c4710dd54073c36733 /Cargo.toml
parentdd72f94a2923223417a1d62cfd1873041247653a (diff)
downloadpin-project-8915193b0de5f14b58aea0cd7bd72a6083529dc2.tar.gz
Update pin-project to 1.0.10
Test: cd external/rust/crates && atest --host -c Change-Id: I60f27e769ab8c287dbf4948e61bae172e6949cfc
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 8 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index be5c598..cc234e1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,21 +3,19 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.37"
name = "pin-project"
-version = "1.0.8"
-authors = ["Taiki Endo <te316e89@gmail.com>"]
+version = "1.0.10"
exclude = ["/.*", "/ci", "/tools"]
description = "A crate for safe and ergonomic pin-projection.\n"
-documentation = "https://docs.rs/pin-project"
keywords = ["pin", "macros", "attribute"]
categories = ["no-std", "rust-patterns"]
license = "Apache-2.0 OR MIT"
@@ -25,8 +23,7 @@ repository = "https://github.com/taiki-e/pin-project"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
[dependencies.pin-project-internal]
-version = "=1.0.8"
-default-features = false
+version = "=1.0.10"
[dev-dependencies.macrotest]
version = "1.0.8"
@@ -37,4 +34,4 @@ version = "1"
version = "1"
[dev-dependencies.trybuild]
-version = "1"
+version = "1.0.49"