aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 6 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 79ba823..f77b1cb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,12 +13,11 @@
[package]
edition = "2018"
name = "pin-project"
-version = "1.0.3"
+version = "1.0.5"
authors = ["Taiki Endo <te316e89@gmail.com>"]
-exclude = ["/.github", "/ci", "/scripts"]
+exclude = ["/.*", "/ci", "/scripts"]
description = "A crate for safe and ergonomic pin-projection.\n"
documentation = "https://docs.rs/pin-project"
-readme = "README.md"
keywords = ["pin", "macros", "attribute"]
categories = ["no-std", "rust-patterns"]
license = "Apache-2.0 OR MIT"
@@ -26,16 +25,16 @@ repository = "https://github.com/taiki-e/pin-project"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
[dependencies.pin-project-internal]
-version = "=1.0.3"
+version = "=1.0.5"
default-features = false
+[dev-dependencies.macrotest]
+version = "1.0.8"
+
[dev-dependencies.rustversion]
version = "1"
[dev-dependencies.static_assertions]
version = "1"
-[dev-dependencies.tempfile]
-version = "3"
-
[dev-dependencies.trybuild]
version = "1"