aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 21 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c4a7dbb..011f0ad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,29 +3,38 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "plotters-svg"
-version = "0.3.1"
+version = "0.3.3"
authors = ["Hao Hou <haohou302@gmail.com>"]
description = "Plotters SVG backend"
homepage = "https://plotters-rs.github.io"
readme = "README.md"
license = "MIT"
-repository = "https://github.com/plotters-rs/plotters-svg.git"
+repository = "https://github.com/plotters-rs/plotters.git"
+
+[dependencies.image]
+version = "0.24.2"
+features = [
+ "jpeg",
+ "png",
+ "bmp",
+]
+optional = true
+default-features = false
+
[dependencies.plotters-backend]
-version = "^0.3.*"
-[dev-dependencies.plotters]
-version = "^0.3.0"
-features = ["ttf"]
-default_features = false
+version = "0.3"
+
+[dev-dependencies]
[features]
+bitmap_encoder = ["image"]
debug = []