summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Geisler <mgeisler@google.com>2023-11-16 12:13:22 +0100
committerMartin Geisler <mgeisler@google.com>2023-11-16 15:33:31 +0100
commit063f6edcc280ad62d643a0cd022fccf1cb6a869e (patch)
tree1d048800858fbab4133f7293e262528b225b5bb4 /Cargo.toml
parent5ca6d8052723b3c36f0c1f5aa60514b1448e9e89 (diff)
downloadpredicates-core-063f6edcc280ad62d643a0cd022fccf1cb6a869e.tar.gz
Import 'predicates-core' crateupstream
Request Document: go/android-rust-importing-crates For CL Reviewers: go/android3p#cl-review For Build Team: go/ab-third-party-imports Bug: 310599818 Change-Id: I662dcdb358a1e058a7c2339e5fb9e4b54d2f7650
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..a1de8f1
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,78 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64.0"
+name = "predicates-core"
+version = "1.0.6"
+authors = ["Nick Stevens <nick@bitcurry.com>"]
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "An API for boolean-valued predicate functions."
+homepage = "https://github.com/assert-rs/predicates-rs/tree/master/crates/core"
+documentation = "https://docs.rs/predicates-core"
+readme = "README.md"
+keywords = [
+ "predicate",
+ "boolean",
+ "combinatorial",
+ "match",
+ "logic",
+]
+categories = [
+ "data-structures",
+ "rust-patterns",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/assert-rs/predicates-rs/tree/master/crates/core"
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "Unreleased"
+replace = "{{version}}"
+min = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = '\.\.\.HEAD'
+replace = "...{{tag_name}}"
+exactly = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "ReleaseDate"
+replace = "{{date}}"
+min = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "<!-- next-header -->"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+exactly = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "<!-- next-url -->"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/assert-rs/predicates-rs/compare/{{tag_name}}...HEAD"""
+exactly = 1