aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 22 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca327e2..43e4376 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,17 +10,17 @@
# See Cargo.toml.orig for the original contents.
[package]
+edition = "2021"
name = "protobuf-codegen"
-version = "2.27.1"
+version = "3.2.0"
authors = ["Stepan Koltsov <stepan.koltsov@gmail.com>"]
description = """
Code generator for rust-protobuf.
-Includes a library and `protoc-gen-rust` binary.
-
-See `protoc-rust` and `protobuf-codegen-pure` crates.
+Includes a library to invoke programmatically (e. g. from `build.rs`) and `protoc-gen-rust` binary.
"""
homepage = "https://github.com/stepancheg/rust-protobuf/"
+readme = "README.md"
license = "MIT"
repository = "https://github.com/stepancheg/rust-protobuf/"
@@ -35,10 +35,23 @@ name = "protoc-gen-rust"
path = "src/bin/protoc-gen-rust.rs"
test = false
-[[bin]]
-name = "protobuf-bin-gen-rust-do-not-use"
-path = "src/bin/protobuf-bin-gen-rust-do-not-use.rs"
-test = false
+[dependencies.anyhow]
+version = "1.0.53"
+
+[dependencies.once_cell]
+version = "1.10.0"
[dependencies.protobuf]
-version = "=2.27.1"
+version = "=3.2.0"
+
+[dependencies.protobuf-parse]
+version = "=3.2.0"
+
+[dependencies.regex]
+version = "1.5.5"
+
+[dependencies.tempfile]
+version = "3"
+
+[dependencies.thiserror]
+version = "1.0.30"