aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid LeGare <legare@google.com>2022-03-02 16:21:10 +0000
committerDavid LeGare <legare@google.com>2022-03-02 16:21:10 +0000
commit793d84b7b9add8be0de7846184d4f21c7fa7c17e (patch)
treee5729062dc903dc271e2bfdc1803bcd03affbeb3 /Cargo.toml
parent460914e0f185cd5ebf81a1720dcc73d302213040 (diff)
downloadprotobuf-793d84b7b9add8be0de7846184d4f21c7fa7c17e.tar.gz
Update protobuf to 2.27.1
Test: cd external/rust/crates && atest --host -c Change-Id: Iaae5fc30f1bd87b2d4a92ee1ae07bc18e1bc50d4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 005d7bf..9e4935f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,19 +12,23 @@
[package]
edition = "2018"
name = "protobuf"
-version = "2.25.1"
+version = "2.27.1"
authors = ["Stepan Koltsov <stepan.koltsov@gmail.com>"]
-description = "Rust implementation of Google protocol buffers\n"
+description = """
+Rust implementation of Google protocol buffers
+"""
homepage = "https://github.com/stepancheg/rust-protobuf/"
documentation = "https://github.com/stepancheg/rust-protobuf/blob/master/README.md"
license = "MIT"
repository = "https://github.com/stepancheg/rust-protobuf/"
+
[package.metadata.docs.rs]
all-features = true
[lib]
doctest = false
bench = false
+
[dependencies.bytes]
version = "1.0"
optional = true
@@ -40,4 +44,7 @@ optional = true
[features]
with-bytes = ["bytes"]
-with-serde = ["serde", "serde_derive"]
+with-serde = [
+ "serde",
+ "serde_derive",
+]