aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml39
1 files changed, 28 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c635f7a..4134e67 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,22 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
[package]
+edition = "2018"
name = "remain"
-version = "0.1.3" # remember to update number in readme for major versions
+version = "0.1.3"
authors = ["David Tolnay <dtolnay@gmail.com>"]
-edition = "2018"
-license = "MIT OR Apache-2.0"
description = "Compile-time checks that an enum, struct, or match is written in sorted order."
-repository = "https://github.com/dtolnay/remain"
documentation = "https://docs.rs/remain"
readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/remain"
[lib]
proc-macro = true
+[dependencies.proc-macro2]
+version = "0.4"
+
+[dependencies.quote]
+version = "0.6"
-[dependencies]
-proc-macro2 = "0.4"
-quote = "0.6"
-syn = { version = "0.15", features = ["full", "visit-mut"] }
+[dependencies.syn]
+version = "0.15"
+features = ["full", "visit-mut"]
+[dev-dependencies.select-rustc]
+version = "0.1"
-[dev-dependencies]
-select-rustc = "0.1"
-trybuild = "1.0"
+[dev-dependencies.trybuild]
+version = "1.0"