aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml36
1 files changed, 27 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bf7879d..cf800d8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,31 +11,45 @@
[package]
edition = "2018"
+rust-version = "1.36"
name = "serde_json"
-version = "1.0.68"
-authors = ["Erick Tryzelaar <erick.tryzelaar@gmail.com>", "David Tolnay <dtolnay@gmail.com>"]
-include = ["build.rs", "src/**/*.rs", "README.md", "LICENSE-APACHE", "LICENSE-MIT"]
+version = "1.0.79"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
description = "A JSON serialization file format"
documentation = "https://docs.serde.rs/serde_json/"
readme = "README.md"
-keywords = ["json", "serde", "serialization"]
+keywords = [
+ "json",
+ "serde",
+ "serialization",
+]
categories = ["encoding"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/serde-rs/json"
+
[package.metadata.docs.rs]
-features = ["raw_value", "unbounded_depth"]
-rustdoc-args = ["--cfg", "docsrs"]
+features = [
+ "raw_value",
+ "unbounded_depth",
+]
targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
[package.metadata.playground]
features = ["raw_value"]
+
[dependencies.indexmap]
version = "1.5"
optional = true
[dependencies.itoa]
-version = "0.4.3"
-default-features = false
+version = "1.0"
[dependencies.ryu]
version = "1.0"
@@ -43,9 +57,13 @@ version = "1.0"
[dependencies.serde]
version = "1.0.100"
default-features = false
+
[dev-dependencies.automod]
version = "1.0"
+[dev-dependencies.ref-cast]
+version = "1.0"
+
[dev-dependencies.rustversion]
version = "1.0"
@@ -59,7 +77,7 @@ version = "1.0"
version = "0.1"
[dev-dependencies.trybuild]
-version = "1.0.19"
+version = "1.0.49"
features = ["diff"]
[features]