aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 22 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cf800d8..08c94aa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.36"
name = "serde_json"
-version = "1.0.79"
+version = "1.0.91"
authors = [
"Erick Tryzelaar <erick.tryzelaar@gmail.com>",
"David Tolnay <dtolnay@gmail.com>",
@@ -26,7 +26,11 @@ keywords = [
"serde",
"serialization",
]
-categories = ["encoding"]
+categories = [
+ "encoding",
+ "parser-implementations",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/serde-rs/json"
@@ -44,8 +48,12 @@ rustdoc-args = [
[package.metadata.playground]
features = ["raw_value"]
+[lib]
+doc-scrape-examples = false
+
[dependencies.indexmap]
-version = "1.5"
+version = "1.5.2"
+features = ["std"]
optional = true
[dependencies.itoa]
@@ -61,12 +69,19 @@ default-features = false
[dev-dependencies.automod]
version = "1.0"
+[dev-dependencies.indoc]
+version = "1.0"
+
[dev-dependencies.ref-cast]
version = "1.0"
[dev-dependencies.rustversion]
version = "1.0"
+[dev-dependencies.serde]
+version = "1.0.100"
+features = ["derive"]
+
[dev-dependencies.serde_bytes]
version = "0.11"
@@ -85,7 +100,10 @@ alloc = ["serde/alloc"]
arbitrary_precision = []
default = ["std"]
float_roundtrip = []
-preserve_order = ["indexmap"]
+preserve_order = [
+ "indexmap",
+ "std",
+]
raw_value = []
std = ["serde/std"]
unbounded_depth = []