aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 20 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e1cca93..f1c192e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,23 +11,35 @@
[package]
edition = "2018"
+rust-version = "1.31"
name = "slab"
-version = "0.4.5"
+version = "0.4.7"
authors = ["Carl Lerche <me@carllerche.com>"]
exclude = ["/.*"]
description = "Pre-allocated storage for a uniform data type"
-homepage = "https://github.com/tokio-rs/slab"
-documentation = "https://docs.rs/slab"
readme = "README.md"
-keywords = ["slab", "allocator", "no_std"]
-categories = ["memory-management", "data-structures", "no-std"]
+keywords = [
+ "slab",
+ "allocator",
+ "no_std",
+]
+categories = [
+ "memory-management",
+ "data-structures",
+ "no-std",
+]
license = "MIT"
repository = "https://github.com/tokio-rs/slab"
+
[dependencies.serde]
version = "1.0.95"
features = ["alloc"]
optional = true
default-features = false
+
+[dev-dependencies.rustversion]
+version = "1"
+
[dev-dependencies.serde]
version = "1"
features = ["derive"]
@@ -35,6 +47,9 @@ features = ["derive"]
[dev-dependencies.serde_test]
version = "1"
+[build-dependencies.autocfg]
+version = "1"
+
[features]
default = ["std"]
std = []