aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 10 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 33ea628..0a4f8cd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@
[package]
rust-version = "1.38"
name = "spin"
-version = "0.9.5"
+version = "0.9.7"
authors = [
"Mathijs van de Nes <git@mathijs.vd-nes.nl>",
"John Ericson <git@JohnEricson.me>",
@@ -35,16 +35,24 @@ rustdoc-args = [
"docsrs",
]
+[[bench]]
+name = "mutex"
+harness = false
+required-features = ["ticket_mutex"]
+
[dependencies.lock_api_crate]
version = "0.4"
optional = true
package = "lock_api"
[dependencies.portable-atomic]
-version = "0.3"
+version = "1"
optional = true
default-features = false
+[dev-dependencies.criterion]
+version = "0.4"
+
[features]
barrier = ["mutex"]
default = [