aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthew Maurer <mmaurer@google.com>2020-06-02 11:15:15 -0700
committerMatthew Maurer <mmaurer@google.com>2020-06-02 11:15:15 -0700
commit32e766957bba962efbe9f27450d29b29b7746603 (patch)
tree4d1d77009e1e028d57f76a1068e815029edb53d2 /Cargo.toml
parentaec9a0556c1eaec17d51413dcd065e0d1d85711c (diff)
downloadstructopt-32e766957bba962efbe9f27450d29b29b7746603.tar.gz
Import structopt-0.3.14
Change-Id: I03e7eaf9f442092701ce3175cb78c8ea2237f616
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..28d6d4b
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "structopt"
+version = "0.3.14"
+authors = ["Guillaume Pinot <texitoi@texitoi.eu>", "others"]
+description = "Parse command line argument by defining a struct."
+documentation = "https://docs.rs/structopt"
+readme = "README.md"
+keywords = ["clap", "cli", "derive", "docopt"]
+categories = ["command-line-interface"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/TeXitoi/structopt"
+[dependencies.clap]
+version = "2.33"
+default-features = false
+
+[dependencies.lazy_static]
+version = "1.4.0"
+
+[dependencies.structopt-derive]
+version = "=0.4.7"
+[dev-dependencies.rustversion]
+version = "1"
+
+[dev-dependencies.trybuild]
+version = "1.0.5"
+features = ["diff"]
+
+[features]
+color = ["clap/color"]
+debug = ["clap/debug"]
+default = ["clap/default"]
+doc = ["clap/doc"]
+lints = ["clap/lints"]
+no_cargo = ["clap/no_cargo"]
+paw = ["structopt-derive/paw"]
+suggestions = ["clap/suggestions"]
+wrap_help = ["clap/wrap_help"]
+yaml = ["clap/yaml"]
+[badges.travis-ci]
+repository = "TeXitoi/structopt"