aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml58
1 files changed, 33 insertions, 25 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0e4c788..20472e4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,18 +10,35 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "textwrap"
-version = "0.15.0"
+version = "0.16.0"
authors = ["Martin Geisler <martin@geisler.net>"]
-exclude = [".github/", ".gitignore", "benches/", "examples/", "fuzz/", "images/"]
-description = "Powerful library for word wrapping, indenting, and dedenting strings"
+exclude = [
+ ".github/",
+ ".gitignore",
+ "benchmarks/",
+ "examples/",
+ "fuzz/",
+ "images/",
+]
+description = "Library for word wrapping, indenting, and dedenting strings. Has optional support for Unicode and emojis as well as machine hyphenation."
documentation = "https://docs.rs/textwrap/"
readme = "README.md"
-keywords = ["text", "formatting", "wrap", "typesetting", "hyphenation"]
-categories = ["text-processing", "command-line-interface"]
+keywords = [
+ "text",
+ "formatting",
+ "wrap",
+ "typesetting",
+ "hyphenation",
+]
+categories = [
+ "text-processing",
+ "command-line-interface",
+]
license = "MIT"
repository = "https://github.com/mgeisler/textwrap"
+
[package.metadata.docs.rs]
all-features = true
@@ -35,15 +52,6 @@ name = "termwidth"
path = "examples/termwidth.rs"
required-features = ["terminal_size"]
-[[bench]]
-name = "linear"
-path = "benches/linear.rs"
-harness = false
-
-[[bench]]
-name = "indent"
-path = "benches/indent.rs"
-harness = false
[dependencies.hyphenation]
version = "0.8.4"
features = ["embed_en-us"]
@@ -54,21 +62,16 @@ version = "0.3.1"
optional = true
[dependencies.terminal_size]
-version = "0.1.17"
+version = "0.2.1"
optional = true
[dependencies.unicode-linebreak]
-version = "0.1.2"
+version = "0.1.4"
optional = true
[dependencies.unicode-width]
-version = "0.1.9"
+version = "0.1.10"
optional = true
-[dev-dependencies.criterion]
-version = "0.3.5"
-
-[dev-dependencies.lipsum]
-version = "0.8.0"
[dev-dependencies.unic-emoji-char]
version = "0.9.0"
@@ -77,6 +80,11 @@ version = "0.9.0"
version = "0.9.4"
[features]
-default = ["unicode-linebreak", "unicode-width", "smawk"]
+default = [
+ "unicode-linebreak",
+ "unicode-width",
+ "smawk",
+]
+
[target."cfg(unix)".dev-dependencies.termion]
-version = "1.5.6"
+version = "2.0.1"