aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2021-01-07 18:06:50 -0800
committerHaibo Huang <hhb@google.com>2021-01-07 18:06:50 -0800
commit7cd98bbfd7a374a005eda423eeace5539ec0a066 (patch)
treeba0351c97d9ed66538c4c26015dd411b0ad9f0be /Cargo.toml
parenta07647964f99c2e99620b88eb3f9b7d58fec4efc (diff)
downloadthread_local-7cd98bbfd7a374a005eda423eeace5539ec0a066.tar.gz
Upgrade rust/crates/thread_local to 1.1.0
Test: make Change-Id: I0c0348cb22330ebd6c6be633525da259fe14fb0c
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0ce59da..5f47295 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@
[package]
name = "thread_local"
-version = "1.0.1"
+version = "1.1.0"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "Per-object thread-local storage"
documentation = "https://amanieu.github.io/thread_local-rs/thread_local/index.html"
@@ -20,7 +20,18 @@ readme = "README.md"
keywords = ["thread_local", "concurrent", "thread"]
license = "Apache-2.0/MIT"
repository = "https://github.com/Amanieu/thread_local-rs"
+
+[[bench]]
+name = "thread_local"
+harness = false
+required-features = ["criterion"]
+[dependencies.criterion]
+version = "0.3.3"
+optional = true
+
[dependencies.lazy_static]
version = "1.0"
+
+[dev-dependencies]
[badges.travis-ci]
repository = "Amanieu/thread_local-rs"