summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorElie Kheirallah <khei@google.com>2023-04-26 17:48:55 +0000
committerElie Kheirallah <khei@google.com>2023-04-26 18:08:58 +0000
commitf15993e47f3f2c7956a835718e293404dfa656cc (patch)
treea31bed2764f5d9586d04c28760a488041927b870 /Cargo.toml
parent68f642b0da87cdbce88eb85314781f1b44af56ae (diff)
downloadthreadpool-f15993e47f3f2c7956a835718e293404dfa656cc.tar.gz
Import libthreadpool crate.
Bug: 278781569 Test: m Change-Id: Ib0ca4698bd9798dfbfdd658fb510f95f72822de2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..f1ace53
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "threadpool"
+version = "1.8.1"
+authors = ["The Rust Project Developers", "Corey Farwell <coreyf@rwell.org>", "Stefan Schindler <dns2utf8@estada.ch>"]
+include = ["**/*.rs", "Cargo.toml", "CHANGES.md", "LICENSE-APACHE", "LICENSE-MIT"]
+description = "A thread pool for running a number of jobs on a fixed set of worker threads.\n"
+homepage = "https://github.com/rust-threadpool/rust-threadpool"
+documentation = "https://docs.rs/threadpool"
+readme = "README.md"
+keywords = ["threadpool", "thread", "pool", "threading", "parallelism"]
+categories = ["concurrency", "os"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-threadpool/rust-threadpool"
+[dependencies.num_cpus]
+version = "1.13"