aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Vander Stoep <jeffv@google.com>2021-11-16 11:16:30 +0100
committerJeff Vander Stoep <jeffv@google.com>2021-11-16 11:17:30 +0100
commit1db412d2c35d13b9d4b8ab28ca56de5b77abff71 (patch)
treea86a1094890ceb522b599e1f37f24c2e16239fd3 /Cargo.toml
parente16ac718df3b8af3bef9bc0c1b6c9bfb5f8e71e1 (diff)
downloadtokio-1db412d2c35d13b9d4b8ab28ca56de5b77abff71.tar.gz
Update to 1.14.0
Test: atest Change-Id: I713529f5ba957c212f50bde27b4428612dbcdefd
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 8 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c09b22a..ec9b335 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,21 +3,20 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "tokio"
-version = "1.12.0"
+version = "1.14.0"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/1.12.0/tokio/"
+documentation = "https://docs.rs/tokio/1.14.0/tokio/"
readme = "README.md"
keywords = ["io", "async", "non-blocking", "futures"]
categories = ["asynchronous", "network-programming"]
@@ -57,7 +56,7 @@ optional = true
version = "0.2.0"
[dependencies.tokio-macros]
-version = "1.1.0"
+version = "1.6.0"
optional = true
[dev-dependencies.async-stream]
version = "0.3"
@@ -112,7 +111,7 @@ features = ["futures", "checkpoint"]
version = "0.6.0"
features = ["tokio"]
[target."cfg(tokio_unstable)".dependencies.tracing]
-version = "0.1.21"
+version = "0.1.25"
features = ["std"]
optional = true
default-features = false