aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2021-01-14 17:23:22 -0800
committerJeff Vander Stoep <jeffv@google.com>2021-01-15 20:44:08 +0100
commit290fc4903cd00fc31d93e0ecd49c402e6833c569 (patch)
tree4a9646d2ab712bae1ead875992160c7248588daf /Cargo.toml
parent84cad6596f48e471881980dcba7df9cb5b4b0139 (diff)
downloadtokio-290fc4903cd00fc31d93e0ecd49c402e6833c569.tar.gz
Upgrade rust/crates/tokio to 1.0.2platform-tools-31.0.0
Test: make Change-Id: Ic48ff709bade266749eac8c146856901ce78da7f
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml56
1 files changed, 26 insertions, 30 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c363565..8e9ebcb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,11 @@
[package]
edition = "2018"
name = "tokio"
-version = "0.3.4"
+version = "1.0.2"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/0.3.4/tokio/"
+documentation = "https://docs.rs/tokio/1.0.2/tokio/"
readme = "README.md"
keywords = ["io", "async", "non-blocking", "futures"]
categories = ["asynchronous", "network-programming"]
@@ -28,17 +28,9 @@ all-features = true
rustdoc-args = ["--cfg", "docsrs"]
[package.metadata.playground]
-features = ["full"]
+features = ["full", "test-util"]
[dependencies.bytes]
-version = "0.6.0"
-optional = true
-
-[dependencies.futures-core]
-version = "0.3.0"
-optional = true
-
-[dependencies.lazy_static]
-version = "1.4.0"
+version = "1.0.0"
optional = true
[dependencies.memchr]
@@ -53,6 +45,10 @@ optional = true
version = "1.8.0"
optional = true
+[dependencies.once_cell]
+version = "1.5.2"
+optional = true
+
[dependencies.parking_lot]
version = "0.11.0"
optional = true
@@ -60,19 +56,12 @@ optional = true
[dependencies.pin-project-lite]
version = "0.2.0"
-[dependencies.slab]
-version = "0.4.1"
-optional = true
-
[dependencies.tokio-macros]
-version = "0.3.0"
+version = "1.0.0"
optional = true
+[dev-dependencies.async-stream]
+version = "0.3"
-[dependencies.tracing]
-version = "0.1.21"
-features = ["std"]
-optional = true
-default-features = false
[dev-dependencies.futures]
version = "0.3.0"
features = ["async-await"]
@@ -83,30 +72,37 @@ version = "0.10.0"
[dev-dependencies.tempfile]
version = "3.1.0"
+[dev-dependencies.tokio-stream]
+version = "0.1"
+
[dev-dependencies.tokio-test]
-version = "0.3.0"
+version = "0.4.0"
[build-dependencies.autocfg]
version = "1"
[features]
default = []
fs = []
-full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "stream", "sync", "time"]
+full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "sync", "time"]
io-std = []
io-util = ["memchr", "bytes"]
macros = ["tokio-macros"]
-net = ["lazy_static", "libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds"]
-process = ["bytes", "lazy_static", "libc", "mio/os-poll", "mio/os-util", "mio/uds", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
-rt = ["slab"]
+net = ["libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds"]
+process = ["bytes", "once_cell", "libc", "mio/os-poll", "mio/os-util", "mio/uds", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
+rt = []
rt-multi-thread = ["num_cpus", "rt"]
-signal = ["lazy_static", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
-stream = ["futures-core"]
+signal = ["once_cell", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
sync = []
test-util = []
time = []
[target."cfg(loom)".dev-dependencies.loom]
-version = "0.3.5"
+version = "0.4"
features = ["futures", "checkpoint"]
+[target."cfg(tokio_unstable)".dependencies.tracing]
+version = "0.1.21"
+features = ["std"]
+optional = true
+default-features = false
[target."cfg(unix)".dependencies.libc]
version = "0.2.42"
optional = true