aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2021-06-22 09:28:11 -0700
committerJoel Galenson <jgalenson@google.com>2021-06-22 09:28:30 -0700
commitb53dd06ad19d902c2155b2f616725b14b423a776 (patch)
treeb92904fad1f985434ad7622c3960e6e670b1c918 /Cargo.toml
parent8c2e0e8165f4f0132f3a5c78337fbba15b102768 (diff)
downloadtokio-b53dd06ad19d902c2155b2f616725b14b423a776.tar.gz
Upgrade rust/crates/tokio to 1.7.1
Test: make Change-Id: I7ebd839df13023db6f2057e09d8b73967436b856
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 11 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 85a245a..8ef52f2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,11 @@
[package]
edition = "2018"
name = "tokio"
-version = "1.6.0"
+version = "1.7.1"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/1.6.0/tokio/"
+documentation = "https://docs.rs/tokio/1.7.1/tokio/"
readme = "README.md"
keywords = ["io", "async", "non-blocking", "futures"]
categories = ["asynchronous", "network-programming"]
@@ -72,6 +72,9 @@ version = "1"
[dev-dependencies.rand]
version = "0.8.0"
+[dev-dependencies.socket2]
+version = "0.4"
+
[dev-dependencies.tempfile]
version = "3.1.0"
@@ -85,12 +88,12 @@ version = "1"
[features]
default = []
-fs = ["libc"]
+fs = []
full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "sync", "time"]
io-std = []
io-util = ["memchr", "bytes"]
macros = ["tokio-macros"]
-net = ["libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds"]
+net = ["libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds", "winapi/namedpipeapi"]
process = ["bytes", "once_cell", "libc", "mio/os-poll", "mio/os-util", "mio/uds", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
rt = []
rt-multi-thread = ["num_cpus", "rt"]
@@ -107,14 +110,14 @@ features = ["std"]
optional = true
default-features = false
[target."cfg(unix)".dependencies.libc]
-version = "0.2.87"
+version = "0.2.42"
optional = true
[target."cfg(unix)".dependencies.signal-hook-registry]
version = "1.1.1"
optional = true
[target."cfg(unix)".dev-dependencies.libc]
-version = "0.2.87"
+version = "0.2.42"
[target."cfg(unix)".dev-dependencies.nix]
version = "0.19.0"
@@ -122,3 +125,5 @@ version = "0.19.0"
version = "0.3.8"
optional = true
default-features = false
+[target."cfg(windows)".dev-dependencies.ntapi]
+version = "0.3.6"