aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2020-10-05 08:16:15 -0700
committerJoel Galenson <jgalenson@google.com>2020-10-05 08:16:15 -0700
commitf03b3ba785a6d336884bfc525046906f8c2a9904 (patch)
tree14e2bd707d8d152ea0476ec9e686deb2a2f55b34 /Cargo.toml
parent40b8b369b069afb314a9d4bb92be1bdd038979f8 (diff)
downloadtokio-f03b3ba785a6d336884bfc525046906f8c2a9904.tar.gz
Import tokio-0.2.22
Test: None Change-Id: Iea7ee5e62819c9b16dbfad05a6146775df72506a
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml143
1 files changed, 143 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..69c8b11
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,143 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "tokio"
+version = "0.2.22"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio/0.2.22/tokio/"
+readme = "README.md"
+keywords = ["io", "async", "non-blocking", "futures"]
+categories = ["asynchronous", "network-programming"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[package.metadata.playground]
+features = ["full"]
+[dependencies.bytes]
+version = "0.5.0"
+
+[dependencies.fnv]
+version = "1.0.6"
+optional = true
+
+[dependencies.futures-core]
+version = "0.3.0"
+optional = true
+
+[dependencies.iovec]
+version = "0.1.4"
+optional = true
+
+[dependencies.lazy_static]
+version = "1.0.2"
+optional = true
+
+[dependencies.memchr]
+version = "2.2"
+optional = true
+
+[dependencies.mio]
+version = "0.6.20"
+optional = true
+
+[dependencies.num_cpus]
+version = "1.8.0"
+optional = true
+
+[dependencies.parking_lot]
+version = "0.10.0"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.1.1"
+
+[dependencies.slab]
+version = "0.4.1"
+optional = true
+
+[dependencies.tokio-macros]
+version = "0.2.4"
+optional = true
+
+[dependencies.tracing]
+version = "0.1.16"
+features = ["std"]
+optional = true
+default-features = false
+[dev-dependencies.futures]
+version = "0.3.0"
+features = ["async-await"]
+
+[dev-dependencies.futures-test]
+version = "0.3.0"
+
+[dev-dependencies.proptest]
+version = "0.9.4"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[dev-dependencies.tokio-test]
+version = "0.2.0"
+
+[features]
+blocking = ["rt-core"]
+default = []
+dns = ["rt-core"]
+fs = ["rt-core", "io-util"]
+full = ["blocking", "dns", "fs", "io-driver", "io-util", "io-std", "macros", "net", "process", "rt-core", "rt-util", "rt-threaded", "signal", "stream", "sync", "time"]
+io-driver = ["mio", "lazy_static"]
+io-std = ["rt-core"]
+io-util = ["memchr"]
+macros = ["tokio-macros"]
+net = ["dns", "tcp", "udp", "uds"]
+process = ["io-driver", "libc", "mio-named-pipes", "signal", "winapi/consoleapi", "winapi/minwindef", "winapi/threadpoollegacyapiset", "winapi/winerror"]
+rt-core = []
+rt-threaded = ["num_cpus", "rt-core"]
+rt-util = []
+signal = ["io-driver", "lazy_static", "libc", "mio-uds", "signal-hook-registry", "winapi/consoleapi", "winapi/minwindef"]
+stream = ["futures-core"]
+sync = ["fnv"]
+tcp = ["io-driver", "iovec"]
+test-util = []
+time = ["slab"]
+udp = ["io-driver"]
+uds = ["io-driver", "mio-uds", "libc"]
+[target."cfg(loom)".dev-dependencies.loom]
+version = "0.3.4"
+features = ["futures", "checkpoint"]
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.42"
+optional = true
+
+[target."cfg(unix)".dependencies.mio-uds]
+version = "0.6.5"
+optional = true
+
+[target."cfg(unix)".dependencies.signal-hook-registry]
+version = "1.1.1"
+optional = true
+[target."cfg(windows)".dependencies.mio-named-pipes]
+version = "0.1.6"
+optional = true
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.8"
+optional = true
+default-features = false