aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChris Wailes <chriswailes@google.com>2022-12-12 11:43:41 -0800
committerJeff Vander Stoep <jeffv@google.com>2023-01-18 19:48:52 +0100
commitff62579fde0625f6c8923b58c9dc848c97c680e6 (patch)
treec049adb6c0fca041cbb303c8311c1084e4a832cd /Cargo.toml
parentb669ae94fdcda726d88936d028d35187bf41b016 (diff)
downloadtokio-ff62579fde0625f6c8923b58c9dc848c97c680e6.tar.gz
Upgrade tokio to 1.23.0
This project was upgraded with external_updater. Usage: tools/external_updater/updater.sh update rust/crates/tokio For more info, check https://cs.android.com/android/platform/superproject/+/master:tools/external_updater/README.md Test: TreeHugger Change-Id: Id69553d5e858bddcde0de5b9e72d6bb3c08bafb5
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml180
1 files changed, 142 insertions, 38 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ec9b335..4c10770 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,23 +11,48 @@
[package]
edition = "2018"
+rust-version = "1.49"
name = "tokio"
-version = "1.14.0"
+version = "1.23.0"
authors = ["Tokio Contributors <team@tokio.rs>"]
-description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
+description = """
+An event-driven, non-blocking I/O platform for writing asynchronous I/O
+backed applications.
+"""
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/1.14.0/tokio/"
readme = "README.md"
-keywords = ["io", "async", "non-blocking", "futures"]
-categories = ["asynchronous", "network-programming"]
+keywords = [
+ "io",
+ "async",
+ "non-blocking",
+ "futures",
+]
+categories = [
+ "asynchronous",
+ "network-programming",
+]
license = "MIT"
repository = "https://github.com/tokio-rs/tokio"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+ "--cfg",
+ "tokio_unstable",
+]
+rustc-args = [
+ "--cfg",
+ "tokio_unstable",
+]
[package.metadata.playground]
-features = ["full", "test-util"]
+features = [
+ "full",
+ "test-util",
+]
+
[dependencies.bytes]
version = "1.0.0"
optional = true
@@ -37,27 +62,24 @@ version = "2.2"
optional = true
[dependencies.mio]
-version = "0.7.6"
+version = "0.8.4"
optional = true
[dependencies.num_cpus]
version = "1.8.0"
optional = true
-[dependencies.once_cell]
-version = "1.5.2"
-optional = true
-
[dependencies.parking_lot]
-version = "0.11.0"
+version = "0.12.0"
optional = true
[dependencies.pin-project-lite]
version = "0.2.0"
[dependencies.tokio-macros]
-version = "1.6.0"
+version = "1.7.0"
optional = true
+
[dev-dependencies.async-stream]
version = "0.3"
@@ -66,16 +88,7 @@ version = "0.3.0"
features = ["async-await"]
[dev-dependencies.mockall]
-version = "0.10.2"
-
-[dev-dependencies.proptest]
-version = "1"
-
-[dev-dependencies.rand]
-version = "0.8.0"
-
-[dev-dependencies.socket2]
-version = "0.4"
+version = "0.11.1"
[dev-dependencies.tempfile]
version = "3.1.0"
@@ -85,36 +98,120 @@ version = "0.1"
[dev-dependencies.tokio-test]
version = "0.4.0"
+
[build-dependencies.autocfg]
-version = "1"
+version = "1.1"
[features]
default = []
fs = []
-full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "sync", "time"]
+full = [
+ "fs",
+ "io-util",
+ "io-std",
+ "macros",
+ "net",
+ "parking_lot",
+ "process",
+ "rt",
+ "rt-multi-thread",
+ "signal",
+ "sync",
+ "time",
+]
io-std = []
-io-util = ["memchr", "bytes"]
+io-util = [
+ "memchr",
+ "bytes",
+]
macros = ["tokio-macros"]
-net = ["libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds", "winapi/namedpipeapi"]
-process = ["bytes", "once_cell", "libc", "mio/os-poll", "mio/os-util", "mio/uds", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
+net = [
+ "libc",
+ "mio/os-poll",
+ "mio/os-ext",
+ "mio/net",
+ "socket2",
+ "windows-sys/Win32_Foundation",
+ "windows-sys/Win32_Security",
+ "windows-sys/Win32_Storage_FileSystem",
+ "windows-sys/Win32_System_Pipes",
+ "windows-sys/Win32_System_SystemServices",
+]
+process = [
+ "bytes",
+ "libc",
+ "mio/os-poll",
+ "mio/os-ext",
+ "mio/net",
+ "signal-hook-registry",
+ "windows-sys/Win32_Foundation",
+ "windows-sys/Win32_System_Threading",
+ "windows-sys/Win32_System_WindowsProgramming",
+]
rt = []
-rt-multi-thread = ["num_cpus", "rt"]
-signal = ["once_cell", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
+rt-multi-thread = [
+ "num_cpus",
+ "rt",
+]
+signal = [
+ "libc",
+ "mio/os-poll",
+ "mio/net",
+ "mio/os-ext",
+ "signal-hook-registry",
+ "windows-sys/Win32_Foundation",
+ "windows-sys/Win32_System_Console",
+]
stats = []
sync = []
-test-util = ["rt", "sync", "time"]
+test-util = [
+ "rt",
+ "sync",
+ "time",
+]
time = []
+
+[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), not(target_os = \"wasi\")))".dev-dependencies.wasm-bindgen-test]
+version = "0.3.0"
+
+[target."cfg(docsrs)".dependencies.windows-sys]
+version = "0.42.0"
+features = [
+ "Win32_Foundation",
+ "Win32_Security_Authorization",
+]
+
[target."cfg(loom)".dev-dependencies.loom]
-version = "0.5"
-features = ["futures", "checkpoint"]
+version = "0.5.2"
+features = [
+ "futures",
+ "checkpoint",
+]
+
+[target."cfg(not(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\")))".dev-dependencies.rand]
+version = "0.8.0"
+
+[target."cfg(not(any(target_arch = \"wasm32\", target_arch = \"wasm64\")))".dependencies.socket2]
+version = "0.4.4"
+features = ["all"]
+optional = true
+
+[target."cfg(not(any(target_arch = \"wasm32\", target_arch = \"wasm64\")))".dev-dependencies.proptest]
+version = "1"
+
+[target."cfg(not(any(target_arch = \"wasm32\", target_arch = \"wasm64\")))".dev-dependencies.socket2]
+version = "0.4"
+
[target."cfg(target_os = \"freebsd\")".dev-dependencies.mio-aio]
version = "0.6.0"
features = ["tokio"]
+
[target."cfg(tokio_unstable)".dependencies.tracing]
version = "0.1.25"
features = ["std"]
optional = true
default-features = false
+
[target."cfg(unix)".dependencies.libc]
version = "0.2.42"
optional = true
@@ -122,14 +219,21 @@ optional = true
[target."cfg(unix)".dependencies.signal-hook-registry]
version = "1.1.1"
optional = true
+
[target."cfg(unix)".dev-dependencies.libc]
version = "0.2.42"
[target."cfg(unix)".dev-dependencies.nix]
-version = "0.22.0"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8"
-optional = true
+version = "0.24"
+features = [
+ "fs",
+ "socket",
+]
default-features = false
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.42.0"
+optional = true
+
[target."cfg(windows)".dev-dependencies.ntapi]
version = "0.3.6"