aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 7 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8ef52f2..daaa1e6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,11 @@
[package]
edition = "2018"
name = "tokio"
-version = "1.7.1"
+version = "1.10.0"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/1.7.1/tokio/"
+documentation = "https://docs.rs/tokio/1.10.0/tokio/"
readme = "README.md"
keywords = ["io", "async", "non-blocking", "futures"]
categories = ["asynchronous", "network-programming"]
@@ -66,6 +66,9 @@ version = "0.3"
version = "0.3.0"
features = ["async-await"]
+[dev-dependencies.mockall]
+version = "0.10.2"
+
[dev-dependencies.proptest]
version = "1"
@@ -99,7 +102,7 @@ rt = []
rt-multi-thread = ["num_cpus", "rt"]
signal = ["once_cell", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
sync = []
-test-util = []
+test-util = ["rt", "sync", "time"]
time = []
[target."cfg(loom)".dev-dependencies.loom]
version = "0.5"
@@ -120,7 +123,7 @@ optional = true
version = "0.2.42"
[target."cfg(unix)".dev-dependencies.nix]
-version = "0.19.0"
+version = "0.22.0"
[target."cfg(windows)".dependencies.winapi]
version = "0.3.8"
optional = true