aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 7 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index da14246..db23f03 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,11 @@
[package]
edition = "2018"
name = "tokio"
-version = "0.3.2"
+version = "0.3.3"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
homepage = "https://tokio.rs"
-documentation = "https://docs.rs/tokio/0.3.2/tokio/"
+documentation = "https://docs.rs/tokio/0.3.3/tokio/"
readme = "README.md"
keywords = ["io", "async", "non-blocking", "futures"]
categories = ["asynchronous", "network-programming"]
@@ -33,10 +33,6 @@ features = ["full"]
version = "0.6.0"
optional = true
-[dependencies.fnv]
-version = "1.0.6"
-optional = true
-
[dependencies.futures-core]
version = "0.3.0"
optional = true
@@ -50,7 +46,7 @@ version = "2.2"
optional = true
[dependencies.mio]
-version = "0.7.3"
+version = "0.7.5"
optional = true
[dependencies.num_cpus]
@@ -73,7 +69,7 @@ version = "0.3.0"
optional = true
[dependencies.tracing]
-version = "0.1.16"
+version = "0.1.21"
features = ["std"]
optional = true
default-features = false
@@ -89,6 +85,8 @@ version = "3.1.0"
[dev-dependencies.tokio-test]
version = "0.3.0"
+[build-dependencies.autocfg]
+version = "1"
[features]
default = []
@@ -103,7 +101,7 @@ rt = ["slab"]
rt-multi-thread = ["num_cpus", "rt"]
signal = ["lazy_static", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
stream = ["futures-core"]
-sync = ["fnv"]
+sync = []
test-util = []
time = []
[target."cfg(loom)".dev-dependencies.loom]