aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoel Galenson <jgalenson@google.com>2021-08-09 10:50:42 -0700
committerJoel Galenson <jgalenson@google.com>2021-08-09 10:50:42 -0700
commitcdef32ccc47be50aeafb1125b30a618283497b71 (patch)
tree014fd32bf139cc7bb53787c6540380976a6a0802 /Cargo.toml
parent1fd699145f300a68d8292e21ccde1df4df236af6 (diff)
downloadunicode-segmentation-cdef32ccc47be50aeafb1125b30a618283497b71.tar.gz
Upgrade rust/crates/unicode-segmentation to 1.8.0
Test: make Change-Id: I84020fc858ae04f9dbf0354d5a811ddff33e4cb1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 12 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0f21309..583df10 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,8 +11,9 @@
# will likely look very different (and much more reasonable)
[package]
+edition = "2018"
name = "unicode-segmentation"
-version = "1.7.1"
+version = "1.8.0"
authors = ["kwantam <kwantam@gmail.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
exclude = ["target/*", "Cargo.lock", "scripts/tmp", "benches/texts/*", "*.txt"]
description = "This crate provides Grapheme Cluster, Word and Sentence boundaries\naccording to Unicode Standard Annex #29 rules.\n"
@@ -26,8 +27,16 @@ repository = "https://github.com/unicode-rs/unicode-segmentation"
[[bench]]
name = "graphemes"
harness = false
-[dev-dependencies.bencher]
-version = "0.1"
+
+[[bench]]
+name = "unicode_words"
+harness = false
+
+[[bench]]
+name = "word_bounds"
+harness = false
+[dev-dependencies.criterion]
+version = "0.3"
[dev-dependencies.quickcheck]
version = "0.7"